Investigating a potential outage

Incident Report for WorldTicket Operational Status

Postmortem

One of our client instances generated high volume of errors, this triggered circuit breaker situation when all nodes of internal gateway cluster stopped accepting further requests and removed themselves from list of load balancers, this situation also propagated to front-facing load-balancers. Normally this situation shouldn’t occur to all nodes of a cluster – circuit breaker concept designed to gracefully handle situation when single node loses connectivity to other services, so requests rerouted to healthy nodes. We adjusted default thresholds for circuit breaker logic, recycled cluster and added more nodes to list of load balancers in order to handle such situations gracefully.

Best Regards,
Worldticket Team

Posted Aug 26, 2021 - 16:57 CEST

Resolved

This incident has been resolved.
Posted Aug 26, 2021 - 16:55 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2021 - 16:55 CEST

Investigating

Dear Customers,

We are currently investigating reports of a potential service interruption with . We apologize for any inconvenience and will post another update as soon as we learn more.

Kind regards ,

Worldticket Team
Posted Aug 26, 2021 - 13:32 CEST
This incident affected: SMS Modules (Reservations, Queues, Pricing, Payment & Ticketing, Inventory & Schedules, Security (Roles & Users), Reporting, Localization).